[otrs-de] Centos 7.7 update OTRS to 6.0.27 - fehlende Perl Module für DB-Update

Nicole Klose nicole.klose at otrs.com
Mi Apr 15 09:29:45 UTC 2020


Hallo Herr Lauffer,

es gibt dazu ein Bug Eintrag, welcher bereits gefixt wurde. 
https://bugs.otrs.org/show_bug.cgi?id=15035

Mit OTRS 6.0.29 sollte Moo also im CheckModules auftauchen.

Liebe Grüße
Nicole

----- Original Message -----
From: "Stephan Lauffer" <lauffer at ph-freiburg.de>
To: "User questions and discussions about OTRS.org in German" <otrs-de at lists.otrs.org>
Sent: Wednesday, April 15, 2020 11:14:20 AM
Subject: Re: [otrs-de]  Centos 7.7 update OTRS to 6.0.27 - fehlende Perl Module für DB-Update

Hallo!

Stimmt, das wollte ich auch noch mitteilen, dass der Perl Module Check  
ein paar neue Module nicht findet/prüft.

Bis vor 6.0.27 lief das bisher problemlos. Aber in 6.0.27 habe ich  
z.B. diese Ausgabe:

otrs at otrs-hx:~> bin/otrs.CheckModules.pl
   o Apache::DBI......................ok (v1.12)
   o Apache2::Reload..................ok (v0.13)
   o Archive::Tar.....................ok (v2.24)
   o Archive::Zip.....................ok (v1.60)
   o Crypt::Eksblowfish::Bcrypt.......ok (v0.009)
   o Date::Format.....................ok (v2.24)
   o DateTime.........................ok (v1.45)
     o DateTime::TimeZone.............ok (v2.15)
     Please consider updating to version 2.20 or higher: This version  
includes recent time zone changes for Chile.
   o DBI..............................ok (v1.639)
   o DBD::mysql.......................ok (v4.046)
   o DBD::ODBC........................Not installed! To install, you  
can use: 'cpan DBD::ODBC'. (optional - Required to connect to a MS-SQL  
database.)
   o DBD::Oracle......................Not installed! To install, you  
can use: 'cpan DBD::Oracle'. (optional - Required to connect to a  
Oracle database.)
   o DBD::Pg..........................Not installed! To install, you  
can use: 'cpan DBD::Pg'. (optional - Required to connect to a  
PostgreSQL database.)
   o Digest::SHA......................ok (v5.96)
   o Encode::HanExtra.................ok (v0.23)
   o IO::Socket::SSL..................ok (v2.052)
     Please consider updating to version 2.066 or higher: This version  
fixes email sending (bug#14357).
   o JSON::XS.........................ok (v3.04)
   o List::Util::XS...................ok (v1.46_02)
   o LWP::UserAgent...................ok (v6.26)
   o Mail::IMAPClient.................ok (v3.37)
     o IO::Socket::SSL................ok (v2.052)
     Please consider updating to version 2.066 or higher: This version  
fixes email sending (bug#14357).
     o Authen::SASL...................ok (v2.16)
     o Authen::NTLM...................Not installed! To install, you  
can use: 'cpan Authen::NTLM'. (optional - Required for NTLM  
authentication mechanism in IMAP connections.)
   o ModPerl::Util....................ok (v2.000010)
   o Net::DNS.........................ok (v1.14)
   o Net::LDAP........................ok (v0.65)
   o Net::SMTP........................ok (v3.10)
     Please consider updating to version 3.11 or higher: This version  
fixes email sending (bug#14357).
   o Template.........................ok (v2.27)
   o Template::Stash::XS..............ok (undef)
   o Text::CSV_XS.....................ok (v1.34)
   o Time::HiRes......................ok (v1.9741)
   o XML::LibXML......................ok (v2.0132)
   o XML::LibXSLT.....................ok (v1.95)
   o XML::Parser......................ok (v2.44)
   o YAML::XS.........................ok (v0.59)

Wie man sieht, wird hier z.B. nicht das notwendige moose (und es waren  
noch ein, zwei weitere) gesucht/angezeigt.

Wäre schön, wenn der Perl Module Tester wieder up-to-date wird. :)


Zitat von Götz Reinicke <goetz.reinicke at filmakademie.de>:

> Guten Tag Frau Klose,
>
> ok. Wäre fein, wenn das bei der Installation via rpm mit als  
> Abhängigkeit geprüft wird, dann muss man sich nicht wundern :)
>
> Läuft wieder. Danke & Grüße . Götz
>
>> Am 14.04.2020 um 13:30 schrieb Nicole Klose <nicole.klose at otrs.com>:
>>
>> Hallo Herr Reinicke,
>>
>> für neuere Versionen wird das perl Modul Moo auf Ihrem Server  
>> benötigt. Dies müssen Sie vorab installieren.
>>
>> LG
>> Nicole Klose
>>
>> From: "Götz Reinicke" <goetz.reinicke at filmakademie.de>
>> To: "User questions and discussions about OTRS.org in German"  
>> <otrs-de at lists.otrs.org>
>> Sent: Tuesday, April 14, 2020 1:25:02 PM
>> Subject: [otrs-de] Centos 7.7 update OTRS to 6.0.27 - fehlende Perl  
>> Module für DB-Update
>>
>> Hi,
>>
>> Ich wollte gerade auf OTRS 6.0.27 updaten (von 6.0.25) und bekomme  
>> eine Reihe an fehlenden Perl Modulen angesagt:
>>
>> scripts/DBUpdate-to-6.pl =>
>>
>> Can't locate Moo.pm
>>
>> Can't locate Sub/Quote.pm
>>
>>
>> Was stimmt da bei uns nicht?
>>
>> 	Grüße . Götz



-- 
Liebe Gruesse, with best regards
Stephan Lauffer

Pedagogical University Freiburg - Germany
http://www.ph-freiburg.de/zik/
Fon/ Fax: +49 761 682 -559/ -486

---------------------------------------------------------------------
OTRS mailing list: otrs-de - Webpage: http://otrs.org/
Archive: http://lists.otrs.org/pipermail/otrs-de
To unsubscribe: http://lists.otrs.org/mailman/listinfo/otrs-de
-------------- nächster Teil --------------
Ein Dateianhang mit Binärdaten wurde abgetrennt...
Dateiname   : smime.p7s
Dateityp    : application/pkcs7-signature
Dateigröße  : 2076 bytes
Beschreibung: S/MIME Cryptographic Signature
URL         : <http://lists.otrs.org/pipermail/otrs-de/attachments/20200415/f8c2ba24/attachment-0001.p7s>


Mehr Informationen über die Mailingliste otrs-de